is it needed that subclipse 1.6 will require on the server SVN1.6?
cant it also supported lower version on the server like 1.5?

Because that would really block me from using subclipse 1.6 it is not that i dont want SVN1.6
but i dont control all the servers where i have connections too. Some could be 1.6 others will stay at 1.5 for a while.

johan

On Wed, Feb 18, 2009 at 17:35, Mark Phippard <markphip@gmail.com> wrote:
Subversion 1.6 RC process is started and the first RC should be out
soon.  The major change in SVN 1.6 for Subclipse is the tree conflicts
feature.  This has required a lot of new work to support the feature
and the changes in the notifications etc.  Here is my overall release
plan.

* Wrap up review and applying recent patches that have come in.
* Make a 1.4.x branch from trunk and cut 1.4.8 release from branch.
* Merge the current tree-conflicts branch to trunk and issue a 1.6.0
release from trunk.

1.6 release will require SVN 1.6.  It will not currently support
SVNKit.  I am pretty sure I already have the plugin dependencies right
so that we can trust our 1.6 release to not try to load older versions
of our plugins for JavaHL etc.  If not, I will fix this for 1.4.8.

Since trunk will be tracking the new release and SVN 1.5 support is
likely to be needed for a while, we will keep the 1.4.x branch
supporting SVN 1.5 clients and we will be agressive in backporting
fixes to that branch and issuing new releases.

But as always, work should be done on trunk and only backported to the
release branch.

--
Thanks

Mark Phippard
http://markphip.blogspot.com/

------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1043&dsMessageId=1186893

To unsubscribe from this discussion, e-mail: [dev-unsubscribe@subclipse.tigris.org].