I have updated the Subclipse 1.10 update site to include the latest version of Subversion (1.8.5) as well as SVNKit (1.8.1).

In addition, now that SVNKit is out of Beta and officially release I have changed the Eclipse Marketplace listing for Subclipse so that it now pointing to the update site for Subclipse 1.10.x

--
Thanks

Mark Phippard
http://markphip.blogspot.com/