Login | Register
My pages Projects Community openCollabNet

Discussions > dev > [Subclipse-dev] Subclipse built on OpenSSL-1.0.1i?

subclipse
Discussion topic

Hide all messages in topic

All messages in topic

RE: Re: [Subclipse-dev] Subclipse built on OpenSSL-1.0.1i?

Author george_stein
Full name George Stein
Date 2014-09-01 02:12:59 PDT
Message Mark,

> On Fri, Aug 29, 2014 at 2:08 AM, George Stein wrote:
>
>> Mark,
>>
>> Thanks for uploading the JavaHL.
>> Will there be a new version 1.10.6?
>>
>>
> Not sure if I understand the question. Because things are packaged in
> separate plugins we do not need to release updates to both. So yes, there
> will be a Subclipse 1.10.6 ... when there is something new in Subclipse
> that is worthy of releasing. We do not have to update the Subclipse
> release to update JavaHL.

Thanks for clarifying this
 
> You might be talking about the zipped update site. No, that will not get
> updated with the latest JavaHL. I only update that when I update
> Subclipse. You can just download the update site though and then make your
> own zip.
>
> $ svn export --username guest
> http://subclipse.tig​ris.org/svn/subclips​e/trunk/www/update_1​.10.x/

Indeed I was referring to the zipped update site. We would prefer an official zip file in case of any problems to reproduce but can also live with the download and self generated variant.

Thanks
George

Re: [Subclipse-dev] Subclipse built on OpenSSL-1.0.1i?

Author markphip
Full name Mark Phippard
Date 2014-08-29 13:44:08 PDT
Message On Fri, Aug 29, 2014 at 2:08 AM, George Stein <
svn.4.george_stein@s​pamgourmet.com> wrote:

> Mark,
>
> Thanks for uploading the JavaHL.
> Will there be a new version 1.10.6?
>
>
Not sure if I understand the question. Because things are packaged in
separate plugins we do not need to release updates to both. So yes, there
will be a Subclipse 1.10.6 ... when there is something new in Subclipse
that is worthy of releasing. We do not have to update the Subclipse
release to update JavaHL.

You might be talking about the zipped update site. No, that will not get
updated with the latest JavaHL. I only update that when I update
Subclipse. You can just download the update site though and then make your
own zip.

$ svn export --username guest
http://subclipse.tig​ris.org/svn/subclips​e/trunk/www/update_1​.10.x/


--
Thanks

Mark Phippard
http://markphip.blogspot.com/
Attachments

RE: [Subclipse-dev] Subclipse built on OpenSSL-1.0.1i?

Author george_stein
Full name George Stein
Date 2014-08-28 23:08:46 PDT
Message Mark,

Thanks for uploading the JavaHL.
Will there be a new version 1.10.6?

Thanks
George

P.S.: Sorry for posting on the dev list, it should have been the users list.

Re: [Subclipse-dev] Subclipse built on OpenSSL-1.0.1i?

Author markphip
Full name Mark Phippard
Date 2014-08-28 07:35:43 PDT
Message I posted the JavaHL update this AM


On Thu, Aug 28, 2014 at 9:05 AM, Mark Phippard <markphip at gmail dot com> wrote:

> On Thu, Aug 28, 2014 at 7:46 AM, George Stein <
> svn.4.george_stein@s​pamgourmet.com> wrote:
>
>> Are there any plans to release a new Subclipse based on OpenSSL-1.0.1i
>> that fixed several critical security issues?
>>
>>
> Yes. When I update the binaries for SVN 1.8.10 it will include that. I
> have just been, and continue to be, too busy to get it done. Should be
> somewhat soon though.
>
> FWIW, conclusions I saw were that none of the latest OpenSSL
> vulnerabilities were critical, perhaps not even issues when it comes to
> SVN.
>
> --
> Thanks
>
> Mark Phippard
> http://markphip.blogspot.com/
>



--
Thanks

Mark Phippard
http://markphip.blogspot.com/
Attachments

Re: [Subclipse-dev] Subclipse built on OpenSSL-1.0.1i?

Author markphip
Full name Mark Phippard
Date 2014-08-28 06:05:10 PDT
Message On Thu, Aug 28, 2014 at 7:46 AM, George Stein <
svn.4.george_stein@s​pamgourmet.com> wrote:

> Are there any plans to release a new Subclipse based on OpenSSL-1.0.1i
> that fixed several critical security issues?
>
>
Yes. When I update the binaries for SVN 1.8.10 it will include that. I
have just been, and continue to be, too busy to get it done. Should be
somewhat soon though.

FWIW, conclusions I saw were that none of the latest OpenSSL
vulnerabilities were critical, perhaps not even issues when it comes to
SVN.

--
Thanks

Mark Phippard
http://markphip.blogspot.com/
Attachments

[Subclipse-dev] Subclipse built on OpenSSL-1.0.1i?

Author george_stein
Full name George Stein
Date 2014-08-28 04:46:51 PDT
Message Are there any plans to release a new Subclipse based on OpenSSL-1.0.1i that fixed several critical security issues?

Thanks
George
Messages per page: