Login | Register
My pages Projects Community openCollabNet

Discussions > dev > [Subclipse-dev] Re: [Issue 1646] Synchronize and Update of a new Directory with new Files failed

subclipse
Discussion topic

Hide all messages in topic

All messages in topic

[Subclipse-dev] Re: [Issue 1646] Synchronize and Update of a new Directory with new Files failed

Author selsemore
Full name Stephen Elsemore
Date 2016-02-19 10:13:35 PST
Message On Fri, Feb 19, 2016 at 5:06 PM, <markphip at tigris dot org> wrote:

> ------- Additional comments from markphip at tigris dot org Fri Feb 19 09:06:30
> -0800 2016 -------
> What Steve means is you cannot update a file without also having its
> containing folder. So since you do not
> have the folder at all, you just see the folder as an incoming change and
> it is assumed you will get anything
> beneath it too.
>
> We do need to make sure that there is not some scenario where updating the
> folder brings it in as
> depth=empty.
>
> Generally, we tend to update from the root of our project so just do not
> run into things like this.
>

I did experiment with trying to find a way that updating could bring a
folder in as depth=empty. I tried updating at various levels, updating
folders with property changes, etc. I couldn't find any scenario that
caused this to happen, except for using the "Update to version..." option
and explicitly selecting that level. If anybody discovers a recipe for
such a problem, please post it.

Maybe we can revisit the feasibility of showing the children of the new
folder in the synch view. I do notice that from the command line 'svn
status -u' does include them (I wonder if this has always been the case).
Attachments
Messages per page: