Login | Register
My pages Projects Community openCollabNet

Discussions > announce > [Subclipse-Announce] Fwd: [Subclipse-dev] [ANN] SVNKit 1.7.4 is released!

subclipse
Discussion topic

Back to topic list

[Subclipse-Announce] Fwd: [Subclipse-dev] [ANN] SVNKit 1.7.4 is released!

Author markphip
Full name Mark Phippard
Date 2012-04-13 08:23:06 PDT
Message SVNKit has issued the GA release of their library with support for
Subversion 1.7. For those of you that have been waiting for this to
adopt Subclipse 1.8.x, I have updated the Subclipse update site to
include this version of the library.

I would love to hear from anyone that is happily using Subclipse 1.8.x
with SVNKit. I have not updated our Eclipse Marketplace listing for
Subclipse 1.8.x because I have been waiting for SVNKit to be GA. So
now that it is GA, I would like to update our listing in the
marketplace. It would be great to hear some success stories first
though.

Thanks

Mark



---------- Forwarded message ----------
From: Alexander Kitaev <alexander.kitaev​@svnkit.com>
Date: Fri, Apr 13, 2012 at 8:02 AM
Subject: [Subclipse-dev] [ANN] SVNKit 1.7.4 is released!
To: svnkit-users at svnkit dot com, dev at subversion dot apache dot org,
subversive-dev at eclipse dot org, dev at subclipse dot tigris dot org


Hello All,

We are glad to announce that long awaited SVNKit 1.7.4 is released and
is available for download at http://svnkit.com/download/ page.

Please note, that in order to avoid user's confusion, we've decided to
follow Subversion version numbering, and this first version of SVNKit
which is compatible with Subversion 1.7 has 1.7.4 as a version number,
not 1.7.0.

Major new features of the new SVNKit 1.7.4 are:

- SVNKit 1.7.4 supports both old 1.6 and new 1.7 working copies and
repositories.
- New command-style API (org.tmatesoft.svn.core.wc2), that one may
find more convenient than the old one.
- SVNKit 1.7.4 is binary compatible with the older versions, existing
code will continue to work with the new version.
- SVNKit 1.7.4 includes new JavaHL (org.apache.subversion.javahl)
implementation.
- Java 1.5 or newer is required

We would appreciate your feedback and questions on our mailing list,
or to support at svnkit dot com
You may also submit issues directly at http://issues.tmatesoft.com/

Thanks!

Alexander Kitaev,
TMate Software,
http://subgit.com/ - Safe Svn to Git Migration!
http://svnkit.com/ - Java [Sub]Versioning Library!
http://hg4j.com/ - Java Mercurial Library!
http://sqljet.com/ - Java SQLite Library!

--------------------​--------------------​--------------
http://subclipse.tig​ris.org/ds/viewMessa​ge.do?dsForumId=1043​&dsMessageId=294​8008

To unsubscribe from this discussion, e-mail:
[dev-unsubscribe@sub​clipse.tigris.org].


--
Thanks

Mark Phippard
http://markphip.blogspot.com/

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

[Subclipse-Announce] Fwd: [Subclipse-dev] [ANN] SVNKit 1.7.4 is released! markphip Mark Phippard 2012-04-13 08:23:06 PDT
Messages per page: