Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 12] New - Proxy support not working

subclipse
Discussion topic

Back to topic list

[Issue 12] New - Proxy support not working

Author issues at subclipse dot tigris dot org
Full name issues at subclipse dot tigris dot org
Date 2003-08-17 03:20:22 PDT
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=12

                  Summary: Proxy support not working
                Component: subclipse
                  Version: current
                 Platform: PC
               OS/Version: Windows XP
                      URL:
                   Status: NEW
        Status Whiteboard:
                 Keywords:
               Resolution:
               Issue type: DEFECT
                 Priority: P3
             Subcomponent: core
               AssignedTo: issues@subclipse
               ReportedBy: jochen


Hi,

one of the most important advantages of svn over cvs is the use of the
HTTP protocol. In particular this allows access to a repository through a
firewall, because you can use an HTTP proxy server. In practice, this
doesn't
seem to be working with subclipse.

Here's what I did:

- Started Eclipse with the following command line arguments:

    C:\Prg\Eclipse\eclipse.exe -data c:\jwi\Workspace -vmargs
-Dhttp.proxyHost=​<myproxyhost> -Dhttp.proxyPort=​<myproxyport>
-Dhttp.proxySet=true

- Configured my repository URL as http://svn.collab.net/repos/svn

- Nothing happened.

However, if I change the URL to http://127.0.0.1:8082/repos/svn and
create an SSH tunnel, everything works fine.


Btw, I would think, that the proxy settings should be configurable
per SVN project.


Jochen

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: issues-unsubscribe@s​ubclipse.tigris.org
For additional commands, e-mail: issues-help@subclips​e.tigris.org

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

[Issue 12] New - Proxy support not working issues at subclipse dot tigris dot org issues at subclipse dot tigris dot org 2003-08-17 03:20:22 PDT
Messages per page: