Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 742] New - Multi-project operations not working properly in Eclipse 3.4

subclipse
Discussion topic

Back to topic list

[Issue 742] New - Multi-project operations not working properly in Eclipse 3.4

Author markphip
Full name Mark Phippard
Date 2008-05-13 07:04:16 PDT
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=742
                 Issue #|742
                 Summary|Multi-project operations not working properly in Eclip
                        |se 3.4
               Component|subclipse
                 Version|head
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P2
            Subcomponent|core
             Assigned to|issues@subclipse
             Reported by|markphip






------- Additional comments from markphip at tigris dot org Tue May 13 07:04:15 -0700 2008 -------
We are having users encounter problems with the latest 3.4 when running certain multi-project
operations. This is because in Eclipse 3.2/3.3 if you used a project as the scheduling rule, the lock was
scoped to the entire workspace. So it did not matter how many projects were updated. In 3.4, this was
moved down to lock just the project (which is good). However, this means if we only refer to one
project in the scheduling rule and more than project is involved, the command will fail when it gets to
the second project.

I already fixed a problem related to this when importing a Team Project Set File. It appears, that
choosing a Working Set and performing an update also causes the problem. We need to figure out a
way to more proactively find and fix the places that do this.

The way to resolve the problem is to get the scheduling rule for each project and then use
MultiRule.combine() to combine the array of rules into a single rule for the operation.

« Previous message in topic | 1 of 18 | Next message in topic »

Messages

Show all messages in topic

[Issue 742] New - Multi-project operations not working properly in Eclipse 3.4 markphip Mark Phippard 2008-05-13 07:04:16 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 markphip Mark Phippard 2008-05-13 07:04:43 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 markphip Mark Phippard 2008-07-21 10:59:02 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 lpurvis Levi Purvis 2008-07-21 12:59:10 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 markphip Mark Phippard 2008-07-21 13:01:34 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 lpurvis Levi Purvis 2008-07-21 13:03:43 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 lpurvis Levi Purvis 2008-07-21 13:06:17 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 markphip Mark Phippard 2008-07-21 13:14:18 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 lpurvis Levi Purvis 2008-07-22 13:11:17 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 selsemore Stephen Elsemore 2010-01-25 08:14:04 PST
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 selsemore Stephen Elsemore 2008-05-14 14:41:59 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 markphip Mark Phippard 2008-07-10 05:30:12 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 wglas Wolfgang Glas 2008-07-10 05:40:23 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 markphip Mark Phippard 2008-07-10 05:43:57 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 wglas Wolfgang Glas 2008-07-10 09:53:57 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 wglas Wolfgang Glas 2008-07-11 07:52:35 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 lpurvis Levi Purvis 2008-07-21 10:50:57 PDT
     [Issue 742] Multi-project operations not working properly in Eclipse 3.4 lpurvis Levi Purvis 2008-07-21 10:55:24 PDT
Messages per page: