Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 1660] Subclipse not adding new files to version control

subclipse
Discussion topic

Back to topic list

[Issue 1660] Subclipse not adding new files to version control

Author markphip
Full name Mark Phippard
Date 2016-09-01 05:50:18 PDT
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1660






------- Additional comments from markphip at tigris dot org Thu Sep 1 05:50:17 -0700 2016 -------
> If I create a new file (any extension) in the POM or JAR module the file is
> added to version control, an asterisk icon is displayed over the file and all is
> fine.

I do not recall any feature where Subclipse automatically adds any files to version control. When you create a
new file you should see a ? and you should have to manually add it to version control.

If you are not seeing the ? you might review your ignore settings. There are so many different ways in Eclipse
that a file is ignored. There are the obvious svn:ignore settings but then there is also an ignore list in Eclipse
Team preferences AND in Eclipse any resource that is marked as derived is automatically ignored. You can
see this flag for a file on the Resource properties page. So right-click on file and look at the Resource page.
If Derived is checked it will be ignored and not show as an unversioned file.

« Previous message in topic | 2 of 4 | Next message in topic »

Messages

Show all messages in topic

[Issue 1660] New - Subclipse not adding new files to version control bonanzaone Evandro Pomatti 2016-09-01 05:45:14 PDT
     [Issue 1660] Subclipse not adding new files to version control markphip Mark Phippard 2016-09-01 05:50:18 PDT
     [Issue 1660] Subclipse not adding new files to version control bonanzaone Evandro Pomatti 2016-09-01 06:16:06 PDT
     [Issue 1660] Subclipse not adding new files to version control markphip Mark Phippard 2016-09-01 06:26:54 PDT
Messages per page: