Login | Register
My pages Projects Community openCollabNet

Discussions > issues > AW: Commit problem

subclipse
Discussion topic

Back to topic list

AW: Commit problem

Author =?iso-8859-1?Q?Uli_St=E4rk?= <uli dot staerk at globalways dot net>
Full name =?iso-8859-1?Q?Uli_St=E4rk?= <uli dot staerk at globalways dot net>
Date 2006-01-31 03:03:09 PST
Message I've just managed to delete the file.

 

schaffnix /data/workspace/us/h​tdocs/InternetZentra​le/httpdocs/lib [#] svn add dtaus

svn: warning: 'dtaus' is already under version control

schaffnix /data/workspace/us/h​tdocs/InternetZentra​le/httpdocs/lib [#] svn del dtaus

svn: Working copy 'dtaus' not locked

schaffnix /data/workspace/us/h​tdocs/InternetZentra​le/httpdocs/lib [#] svn cleanup dtaus

svn: 'dtaus' is not a working copy directory

schaffnix /data/workspace/us/h​tdocs/InternetZentra​le/httpdocs/lib [#] rm -rf dtaus

schaffnix /data/workspace/us/h​tdocs/InternetZentra​le/httpdocs/lib [#] svn ci

svn: Commit failed (details follow):

svn: Working copy '/data/workspace/us/​htdocs/InternetZentr​ale/httpdocs/lib/dta​us' not locked

schaffnix /data/workspace/us/h​tdocs/InternetZentra​le/httpdocs/lib [#] svn del dtaus

D dtaus

schaffnix /data/workspace/us/h​tdocs/InternetZentra​le/httpdocs/lib [#] svn ci

 

Can it be, that eclipse imported .svn directory when I dragged the file into my project? Can this cause problems like this?

 

-----Ursprüngliche Nachricht-----
Von: Uli Stärk [mailto:uli.staerk@g​lobalways.net]
Gesendet: Dienstag, 31. Januar 2006 11:22
An: issues at subclipse dot tigris dot org
Betreff: Commit problem

 

I just tried to commit my current changes, when I got the message, that my working copy is up-to-date. But I've definitely changed something: I've copied some files from another project via drag and drop into the current project.

Then I tried to synchronize the project with the repository ... it crashed with the following error:

 

Bad URL passed to RA layer

svn: URL 'svn://<...>/h​ttpdocs/lib/dtaus' non-existent in revision '56'

 

 

org.tigris.subversio​n.javahl.ClientExcep​tion: Working copy not locked; this is probably a bug, please report

svn: Working copy 'Z:\htdocs\Interne​tZentrale\httpdocs​lib\dtaus' is missing or not locked

 

What now? ...\dtaus exists on the drive and there are already .svn dirs in that folder.

 

--------------------​--------------------​--------------------​---------

To unsubscribe, e-mail: issues-unsubscribe@s​ubclipse.tigris.org

For additional commands, e-mail: issues-help@subclips​e.tigris.org
Attachments

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

AW: Commit problem =?iso-8859-1?Q?Uli_St=E4rk?= <uli dot staerk at globalways dot net> =?iso-8859-1?Q?Uli_St=E4rk?= <uli dot staerk at globalways dot net> 2006-01-31 03:03:09 PST
Messages per page: