Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 1643] New - Inconsistent recursive revert

Discussion topic

Hide all messages in topic

All messages in topic

[Issue 1643] Inconsistent recursive revert

Author selsemore
Full name Stephen Elsemore
Date 2016-02-04 04:46:18 PST
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1643

User selsemore changed the following:

                What |Old value |New value
                  Status|NEW |RESOLVED
              Resolution| |FIXED

------- Additional comments from selsemore at tigris dot org Thu Feb 4 04:46:18 -0800 2016 -------

[Issue 1643] New - Inconsistent recursive revert

Author chrisbry
Full name Christian Bryllok
Date 2016-02-04 02:57:10 PST
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1643
                 Issue #|1643
                 Summary|Inconsistent recursive revert
       Status whiteboard|
              Issue type|DEFECT
             Assigned to|issues@subclipse
             Reported by|chrisbry

------- Additional comments from chrisbry at tigris dot org Thu Feb 4 02:57:10 -0800 2016 -------
Eclipse for RCP and RAP Developers

Version: Mars.1 Release (4.5.1)
Build id: 20150924-1200

Subclipse (Required) 1.10.10

Recognized an inconsitent behaviour of the revert action.

Precondition: Versionized project containing the following folder structure:

 --> folder
        --> subfolder 1
                 --> subfolder 1.1


1. Delete folder and try to revert this from project explorer.
=> The revert is not done recursively. To get the content of subfolders 1.1 you
would have to revert three additional times.

2. Delete folder and synchronize the project with the repository. Now revert the
changes with the Synchronize view.
=> Revert is done recursively.

Would expect the revert action in the project explorer also to be recursive.
Messages per page: