Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 1645] New - Runner for 'org.tmatesoft.svn.core.wc2.SvnMerge' command have not been found

subclipse
Discussion topic

Hide all messages in topic

All messages in topic

[Issue 1645] Runner for 'org.tmatesoft.svn.core.wc2.SvnMerge' command have not been found

Author markphip
Full name Mark Phippard
Date 2016-02-17 11:46:15 PST
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1645






------- Additional comments from markphip at tigris dot org Wed Feb 17 11:46:15 -0800 2016 -------
Not to pass the buck, but we do not write any code specific to SVNKit.

Subclipse is ultimately written to the JavaHL API. We have a layer that can swap in the native implementation
provided by Subversion or SVNKit's implementation. They supply the JavaHL interface implementation so
that is where this error would be coming from.

They said they do not support 1.9 yet so that might be the issue as you downloaded the version of Subclipse
for SVN 1.9 JavaHL. That said, I thought the version of SVNKit included was just identical to what is in our 1.8
version. Maybe something "bleeds" into this but I do not think so. I would guess you would see this same
issue if you use Subclipse 1.10.x in which case you would need to get a better answer from them about what
the error might be.

[Issue 1645] Runner for 'org.tmatesoft.svn.core.wc2.SvnMerge' command have not been found

Author bgt
Full name Tomi Suovuo
Date 2016-02-17 11:44:38 PST
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1645






------- Additional comments from bgt at tigris dot org Wed Feb 17 11:44:38 -0800 2016 -------
This occurs when trying to merge a range of revisions from a branch to trunk (all eligible revisions).

[Issue 1645] New - Runner for 'org.tmatesoft.svn.core.wc2.SvnMerge' command have not been found

Author bgt
Full name Tomi Suovuo
Date 2016-02-17 11:41:29 PST
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1645
                 Issue #|1645
                 Summary|Runner for 'org.tmatesoft.svn.c​ore.wc2.SvnMerge' comma
                        |nd have not been found
               Component|subclipse
                 Version|1.10.x
                Platform|SVNKit
              OS/Version|Mac OS X
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|core
             Assigned to|issues@subclipse
             Reported by|bgt






------- Additional comments from bgt at tigris dot org Wed Feb 17 11:41:28 -0800 2016 -------
People are reporting this fault to tmatesoft, as the error message originates from SVNKit.

https://issues.tmate​soft.com/issue/SVNKI​T-554

At tmatesoft, however, they respond that "SVNKit is just a library and we can't check and fix the
way it is used in this or that SVN support plugin. So probably you would rather report the bug to
the plugin developers. Or if you know particular Java code that is not working, please post here.
Note that JavaHL 1.9 is not supported yet, we are working on 1.9 support now."

The full error report in Eclipse console is:

merge https://mergesource-URL /Users/bgt/Documents​/workspace/mergetarg​etproject
    svn: E200007: Runner for 'org.tmatesoft.svn.c​ore.wc2.SvnMerge' command have not been
found; probably not yet implement in this API.
    svn: E200007: Runner for 'org.tmatesoft.svn.c​ore.wc2.SvnMerge' command have not been
found; probably not yet implement in this API.
    Merge completed abnormally.


For me this is a fresh install of Eclipse Mars with all items freshly installed from
http://subclipse.tig​ris.org/update_1.12.​x

I also had same problem with Aptana Studio 3.
Messages per page: