Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 1656] New - directory compare doesn't work

subclipse
Discussion topic

Hide all messages in topic

All messages in topic

[Issue 1656] directory compare doesn't work

Author markphip
Full name Mark Phippard
Date 2016-08-12 12:33:27 PDT
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1656






------- Additional comments from markphip at tigris dot org Fri Aug 12 12:33:26 -0700 2016 -------
I take that back slightly. It seems to work fine if I do it on the Project (which is a folder). But if I go deeper
and do it on a subfolder I see an incorrect result.

It works fine with JavaHL so you should report this to SVNKit. My guess is they are returning results but the
format of the paths is different than JavaHL so it does not show the right result. It is up to SVNKit to 100%
emulate JavaHL so they would need to look into this.

[Issue 1656] directory compare doesn't work

Author markphip
Full name Mark Phippard
Date 2016-08-12 12:27:29 PDT
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1656






------- Additional comments from markphip at tigris dot org Fri Aug 12 12:27:28 -0700 2016 -------
This project is Subclipse. SVNKit is an implementation of the Subversion API that Subclipse can talk to, but
we only validate and test against JavaHL. If something is truly wrong with SVNKit, then you need to report it
to support at svnkit dot com and provide them details.

You mention "Directory Compare". That could mean a lot of different things so can you be more precise?

I used the latest Subclipse release (1.10.13) and tried it using JavaHL (1.9.4) and SVNKit (1.8.12). What I did
was had an outdated working copy, select a folder and do Compare with > Latest from Repository. Which is
what I would consider to be Directory Compare. That works fine in all cases.

If you want to provide details for another scenario of directory compare I can try it and see if I see a problem
with these versions.

[Issue 1656] New - directory compare doesn't work

Author paulc98mdt
Full name Paul Cheng
Date 2016-08-01 12:55:02 PDT
Message http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1656
                 Issue #|1656
                 Summary|directory compare doesn't work
               Component|subclipse
                 Version|1.8.x
                Platform|SVNKit
              OS/Version|Linux
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|core
             Assigned to|issues@subclipse
             Reported by|paulc98mdt






------- Additional comments from paulc98mdt at tigris dot org Mon Aug 1 12:55:01 -0700 2016 -------
One of the nice feature we like in SVNKit is the ability to do "directory
compare", however, the feature stops working in the SVNKit version 1.8.x and
above even although "file compare" still seems working.

Due to this limitation, we can't migrate from SVNKit 1.7.9 to the latest
version.

It would be appreciate if someone can get this issue fixed.
Messages per page: