Login | Register
My pages Projects Community openCollabNet

Discussions > users > RE: Re: Re: Re: Re: [Subclipse-users] Branch merge issues

subclipse
Discussion topic

Back to topic list

RE: Re: Re: Re: Re: [Subclipse-users] Branch merge issues

Author scolebourne
Full name Stephen Colebourne
Date 2009-05-27 10:45:26 PDT
Message > > Here is an example that shows the eligible revs from the Subclipse
> > trunk that can be merged to the Subclipse 1.4.x branch.
> >
> > $ svn mergeinfo --show-revs=eligible
> > http://subclipse.tig​ris.org/svn/subclips​e/trunk/subclipse@HE​AD
> > http://subclipse.tig​ris.org/svn/subclips​e/branches/1.4.x/sub​clipse@HEAD

OK. So, if I run from the command line:

svn mergeinfo --show-revs=eligible http://repo/svn/base​/trunk/eclipseprojec​ta@HEAD http://repo/svn/base​/branches/1.0/eclips​eprojecta@HEAD

I get an accurate set of results near instantly.

However, if I run from the command line:

svn mergeinfo --show-revs=eligible http://repo/svn/base/trunk@HEAD http://repo/svn/base​/branches/1.0/eclips​eprojecta@HEAD

(note the missing eclipseprojecta) then I get a slow response consisting of every revision in the repository. (Which is of course the result we'd expect for this 'wrong' command')

The response time isn't as slow as a multi-project merge in the Collabnet merge client, but if this wrong command were run once for each eclipse project, then the total time would be about right.

Further info: If the Collabnet merge client is used to merge one project, then the results are the 'correct' set.

If the Collabnet merge client is use to merge two (or more) eclipse projects, lets say a and b, then the offered revisions are not in any way filtered to projects a and b. In other words, they include revisions that only affect projects c, d and e.

As a result, I can pick a revision that only affected c, and the merge client will attempt to apply that revision via a merge to a and b, which obviously has no effect.

I can't really see anything special in my Eclipse setup. Each eclipse project points to part of a full checkout from /branches/1.0, so there is no issue with the working copy that I can see.

Thus far, the only way to reproduce the issue I have at the command line is by issuing the wrong command that compares the shared base folder with the specific eclipse project sub-folder. Unfortunately, Collabnet/Subclipse doesn't log the svn mergeinfo command, so I can't prove that the command being sent from Subclipse is wrong. But I can't find any other explanation.

Suggestions?

Stephen

« Previous message in topic | 11 of 20 | Next message in topic »

Messages

Show all messages in topic

[Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-22 09:51:08 PDT
     Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-22 10:44:40 PDT
         RE: Re: [Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-23 03:22:14 PDT
             Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-23 06:16:35 PDT
                 RE: Re: Re: [Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-26 06:26:32 PDT
                     Re: Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-26 06:40:42 PDT
                         RE: Re: Re: Re: [Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-26 08:40:19 PDT
                             Re: Re: Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-26 09:04:45 PDT
                                 RE: Re: Re: Re: Re: [Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-27 05:34:45 PDT
                                     Re: Re: Re: Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-27 10:31:26 PDT
                                     RE: Re: Re: Re: Re: [Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-27 10:45:26 PDT
                                         Re: Re: Re: Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-27 10:51:19 PDT
                                             RE: Re: Re: Re: Re: Re: [Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-28 00:49:30 PDT
                                                 RE: Re: Re: Re: Re: Re: [Subclipse-users] Branch merge issues scolebourne Stephen Colebourne 2009-05-28 00:50:59 PDT
                                                 Re: Re: Re: Re: Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-06-02 07:44:53 PDT
                                                     Re: Re: Re: Re: Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-06-02 10:58:38 PDT
                                                         Re: Re: Re: Re: Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-06-11 12:15:58 PDT
                 Re: Re: [Subclipse-users] Branch merge issues jcompagner jcompagner 2009-05-26 07:11:57 PDT
                     Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-26 07:25:53 PDT
                     Re: Re: [Subclipse-users] Branch merge issues markphip Mark Phippard 2009-05-26 07:26:03 PDT
Messages per page: