Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: [Subclipse-users] Can't seem to get svnkit client to show up

subclipse
Discussion topic

Back to topic list

Re: [Subclipse-users] Can't seem to get svnkit client to show up

Author markphip
Full name Mark Phippard
Date 2011-10-24 15:51:55 PDT
Message There is really mot much to do. Everything is on our update site.

For Subclipse 1.6.x we include JavaHL + SVNKit on the update site.

For Subclipse 1.8.x we include JavaHL. SVNKit will not support SVN
1.7 for a few months so it will not appear on the 1.8.x update site
until then.

Subclipse 1.8.x includes 32/64-bit JavaHL for Windows. So this has
everything you need to just work.

Subclipse 1.6.x only includes 32-bit JavaHL. If you run 32-bit
Eclipse with a 32-bit JVM it will run fine. Unless you need a >4GB
Heap for some reason, this is the fastest way to run Eclipse anyway.
If you must use 64-bit then you need to have 64-bit JavaHL library in
your PATH. Easiest way to do that is to install SlikSVN 64-bit client
for 1.6 as it includes JavaHL.


On Mon, Oct 24, 2011 at 6:13 PM, Chris <shef31 at yahoo dot com> wrote:
> I've installed subclipse with all the options, but when I go to Window /
> Preferences /Team / SVN / SVN Client Interface, only JavaHL shows up in
> the dropdown, not svnkit.
>
> I went to the svnkit eclipse update site and installed it, but still
> nothing.
>
> The answer on StackOverflow doesn't work:
>
> http://stackoverflow​.com/questions/67303​94/svnkit-with-subcl​ipse-under-eclipse-i​ndigo
>
> The reason I want svnkit is that it just works, and it's what I used on
> previous versions of Eclipse. I'm pulling my hair out getting javahl
> configured correctly.
>
> How do I get the svnkit client adapter installed?
>
> (Environment: Eclipse Indigo, 64 bit Windows 7)
>
> --------------------​--------------------​--------------
> http://subclipse.tig​ris.org/ds/viewMessa​ge.do?dsForumId=1047​&dsMessageId=286​2522
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe@s​ubclipse.tigris.org]​.
>



--
Thanks

Mark Phippard
http://markphip.blogspot.com/

« Previous message in topic | 2 of 8 | Next message in topic »

Messages

Show all messages in topic

[Subclipse-users] Can't seem to get svnkit client to show up Chris <shef31 at yahoo dot com> Chris <shef31 at yahoo dot com> 2011-10-24 15:14:09 PDT
     Re: [Subclipse-users] Can't seem to get svnkit client to show up markphip Mark Phippard 2011-10-24 15:51:55 PDT
         Re: [Subclipse-users] Can't seem to get svnkit client to show up Chris <shef31 at yahoo dot com> Chris <shef31 at yahoo dot com> 2011-10-24 19:30:17 PDT
             Re: [Subclipse-users] Can't seem to get svnkit client to show up markphip Mark Phippard 2011-10-25 09:44:34 PDT
         Re: [Subclipse-users] Can't seem to get svnkit client to show up Chris <shef31 at yahoo dot com> Chris <shef31 at yahoo dot com> 2011-10-25 08:48:24 PDT
             Re: [Subclipse-users] Can't seem to get svnkit client to show up Chris <shef31 at yahoo dot com> Chris <shef31 at yahoo dot com> 2011-10-25 13:44:32 PDT
                 Re: [Subclipse-users] Can't seem to get svnkit client to show up markphip Mark Phippard 2011-10-25 14:01:47 PDT
                     Re: [Subclipse-users] Can't seem to get svnkit client to show up Chris <shef31 at yahoo dot com> Chris <shef31 at yahoo dot com> 2011-10-25 14:38:44 PDT
Messages per page: