Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: Re: [Subclipse-users] Subclipse bug report - proxy settings not synchronized with eclipse settings

subclipse
Discussion topic

Back to topic list

Re: Re: [Subclipse-users] Subclipse bug report - proxy settings not synchronized with eclipse settings

Author markphip
Full name Mark Phippard
Date 2014-11-13 05:46:27 PST
Message On Thu, Nov 13, 2014 at 5:02 AM, Arno Unkrig <arno at unkrig dot de> wrote:

> Looking at the code of the SVNKIT adapter, it should be possible to modify
> it such that the adapter uses the ECLIPSE proxy configuration instead of
> its 'own'. I desperately need this, because I cannot put my proxy password
> in clear text into the 'servers' file!
>

We do not develop SVNKit (or JavaHL) in this project, we simply use them.
AFAIK, SVNKit already uses the Eclipse proxy configuration and has for
several years. Are you using SVNKit adapter? The comment you quoted below
is about the Subversion API (JavaHL). It does not currently expose an API
for giving it configuration information like proxy server.



>
> > We need API from Subversion to do this. There are
> > open requests
> > tentatively planned for the 1.6 release.
>

--
Thanks

Mark Phippard
http://markphip.blogspot.com/
Attachments

« Previous message in topic | 4 of 4 | Next message in topic »

Messages

Show all messages in topic

Subclipse bug report - proxy settings not synchronized with eclipse settings Tomasz Zielinski <tomasz dot zielinski at gmail dot com> Tomasz Zielinski <tomasz dot zielinski at gmail dot com> 2007-12-13 01:52:03 PST
     Re: [Subclipse-users] Subclipse bug report - proxy settings not synchronized with eclipse settings Mark Phippard <markphip at gmail dot com> Mark Phippard <markphip at gmail dot com> 2007-12-13 05:41:18 PST
         RE: Re: [Subclipse-users] Subclipse bug report - proxy settings not synchronized with eclipse settings arno_unkrig Arno Unkrig 2014-11-13 02:02:43 PST
             Re: Re: [Subclipse-users] Subclipse bug report - proxy settings not synchronized with eclipse settings markphip Mark Phippard 2014-11-13 05:46:27 PST
Messages per page: