Login | Register
My pages Projects Community openCollabNet

Discussions > users > [Subclipse-users] Unfriendly GNOME keyring prompt

subclipse
Discussion topic

Back to topic list

[Subclipse-users] Unfriendly GNOME keyring prompt

Author "Fitzpatrick, Ben" <ben dot fitzpatrick at metoffice dot gov dot uk>
Full name "Fitzpatrick, Ben" <ben dot fitzpatrick at metoffice dot gov dot uk>
Date 2014-11-17 05:25:38 PST
Message Hi,

If you have a default (or blank) Subversion 1.8 ~/.subversion/config and use Subclipse with JavaHL, you'll get prompted on startup of Eclipse to 'allow Subclipse to remove the current password-stores value from the configuration file' (because GNOME keyring password storage doesn't work with JavaHL).

If you click 'OK', the config file will contain a line that reads:

password-stores =

which is a blank value, disabling *all* proper password storage services, not just GNOME keyring.

This is not very friendly and means that services that work fine (e.g. gpg-agent) can't be used without tweaking the configuration back. It also messes with other subversion clients which can use GNOME keyring without any problems.

Should the default behaviour of the prompt be changed so that it allows the other services to be used? Should it automatically use a different configuration directory (http://permalink.gma​ne.org/gmane.comp.ve​rsion-control.subver​sion.subclipse.user/​16665) and dump the changed config there?

Cheers,

Ben Fitzpatrick

« Previous message in topic | 1 of 2 | Next message in topic »

Messages

Show all messages in topic

[Subclipse-users] Unfriendly GNOME keyring prompt "Fitzpatrick, Ben" <ben dot fitzpatrick at metoffice dot gov dot uk> "Fitzpatrick, Ben" <ben dot fitzpatrick at metoffice dot gov dot uk> 2014-11-17 05:25:38 PST
     Re: [Subclipse-users] Unfriendly GNOME keyring prompt markphip Mark Phippard 2014-11-17 06:13:19 PST
Messages per page: