Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work?

subclipse
Discussion topic

Back to topic list

Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work?

Author markphip
Full name Mark Phippard
Date 2016-03-07 09:26:41 PST
Message On Mon, Mar 7, 2016 at 11:12 AM, Peter Toennies <pgtoennies at gmail dot com>
wrote:

> Hi. I am on a project where we have a Subversion server that is using
> version
> 1.7.14. I have a client machine that has Subversion version 1.6.11. I am
> trying to use the Subclipse plugin version 1.6.18 from
> http://subclipse.tig​ris.org/servlets/Pro​jectDocumentList?fol​derID=2240.
> Unfortunately, I cannot get it to work. I was told that I needed to upgrade
> my Subversion client version to match the Subversion server version. I do
> not understand why this is necessary. Here is what I have installed under
> installation details:
>

Subversion clients and servers do NOT need to be running the same version.
Subclipse does not do anything that would change this or make it a
requirement.




>
> <
> http://tigris-scm.10​930.n7.nabble.com/fi​le/n100368/%24740C7F​C3AD917C29.jpg
> >
>
> We are using Python on our project and I have the PyDev plugin installed.
> The import of a svn repository is failing. Here is what I am doing and
> seeing:
>
> 1. From "PyDev Package Explorer", right-click and select "Import"
> 2. Under SVN select "Checkout Projects from SVN" and press Next
> 3. Select "Create a new repository"
> 4. Enter the URL for the svn repository and press Next
>
> Next I get an error message like the following, "Error validating location:
> "org.tigris.subversi​on.javahl.ClientExce​ption: svn: URL '<url name here>'
> non-existent in revision '<revision number>'.. Keep location anyway"
>
> 5. Next I select "Yes"
> 6. Next I am shown an error message, 'Folder " does not exist remotely.'
> 7. I dismiss this error message. Then I select the top folder of the
> repository.
> 8. Next I select "Check out as a project in the workspace"
> 9. Next I click on Finish.
>


So why are you doing all of these things? Assuming you have a valid URL it
would seem like the message in step 6 is relevant and you should be
investigating it more.



> 10. Next I am shown a message saying, "You appear to be checking out the
> root of your repository. Are you sure that this is what you want to do?..."
> I answer "Yes"
> 11. Next I get the error message, "'SVN Checkout' has encountered a
> problem.
> Error Getting Dir list"
>


These are all just further signs that you have not entered a valid URL.
What protocol are you using? https:// etc..



--
Thanks

Mark Phippard
http://markphip.blogspot.com/
Attachments

« Previous message in topic | 2 of 7 | Next message in topic »

Messages

Show all messages in topic

[Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 09:08:38 PST
     Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? markphip Mark Phippard 2016-03-07 09:26:41 PST
         Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 12:45:06 PST
             Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? markphip Mark Phippard 2016-03-07 12:50:38 PST
                 Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 12:59:53 PST
                     Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? markphip Mark Phippard 2016-03-07 13:06:22 PST
                         Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 15:28:35 PST
Messages per page: