Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work?

subclipse
Discussion topic

Back to topic list

Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work?

Author rohr22
Full name Peter Toennies
Date 2016-03-07 12:45:06 PST
Message I did exactly the same steps on a machine where Subclipse works correctly and
the one where it doesn't. I entered the same URL for both. I am using the
svn+ssh protocol for specifying the URL. On the machine where I am having an
issue with Subversion 1.6.11, I can run an "svn ls" command on the URL I am
entering into Eclipse in a terminal window. When I enter the URL in
Subclipse and press Next, I get an error message of the form:

Error validating location: "org.tigris.subversi​on.javahl.ClientExce​ption:
svn: URL '<url name here>'
non-existent in revision '<revision number>'.. Keep location anyway"

What should be selected under Window->Preferenc​es->Team->SVN for the "SVN
Interface". On mine I have "SVNKit (Pure Java) SVNKit v1.3.5.7406. Initially
it was set to "JavaHL (JNI)" and had the text "Not Available" after that. Do
I need to do something so that "JavaHL (JNI)" is installed? Where can I get
that from?

Attached is the Help->Installation Details screen on the machine where
Subclipse is not working:
<http://tigris-scm.10​930.n7.nabble.com/fi​le/n100371/%2445DEC6​EEC43A09AB.jpg>

Am I missing some installed software to make Subclipse work correctly with a
client svn version of 1.6.11 with a server svn version of 1.7.14?

Thank you,
Peter



--
View this message in context: http://tigris-scm.10​930.n7.nabble.com/Do​-Subversion-server-a​nd-client-versions-n​eed-to-match-for-Sub​clipse-to-work-tp100​368p100371.html
Sent from the subclipse - users mailing list archive at Nabble.com.

« Previous message in topic | 3 of 7 | Next message in topic »

Messages

Show all messages in topic

[Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 09:08:38 PST
     Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? markphip Mark Phippard 2016-03-07 09:26:41 PST
         Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 12:45:06 PST
             Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? markphip Mark Phippard 2016-03-07 12:50:38 PST
                 Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 12:59:53 PST
                     Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? markphip Mark Phippard 2016-03-07 13:06:22 PST
                         Re: [Subclipse-users] Do Subversion server and client versions need to match for Subclipse to work? rohr22 Peter Toennies 2016-03-07 15:28:35 PST
Messages per page: