Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: [Subclipse-users] Latest Subclipse (1.10.13) Unreliable

subclipse
Discussion topic

Back to topic list

Re: [Subclipse-users] Latest Subclipse (1.10.13) Unreliable

Author jamiejackson
Full name Jamie Jackson
Date 2016-09-08 10:56:00 PDT
Message Thanks, Mark. I think I'll go back to the 1.10.x update site for a while
and see if that is more reliable.

On Thu, Sep 8, 2016 at 10:34 AM, Mark Phippard <markphip at gmail dot com> wrote:

> As you know, we have barely modified the product in several years, so it
> is not like it suddenly changed to become unreliable. The only thing that
> is changing is the SVN client underneath it, so most likely there are some
> kind of behavior changes in SVN 1.9.
>
> The version from the 1.12.x update site is identical to the one in the
> 1.10.x update site. One of them just contains SVN 1.8.x client and the
> other SVN 1.9.x. since you cannot host both versions on one update site.
>
> So perhaps there are some code changes needed for SVN 1.9. The API has
> not changed but maybe its behavior has.
>
> Mark
>
>
>
> On Thu, Sep 8, 2016 at 10:25 AM, Jamie Jackson <jamiejaxon at gmail dot com>
> wrote:
>
>> I've been using Subclipse for probably over a decade now, but the
>> version(s) from the 1.12 updater site have been driving me crazy.
>>
>> I'm getting:
>>
>>
>> 1. Hung merges
>> 2. An issue with failed switches blocking any other SVN operations
>> from running <http://subclipse.tig​ris.org/issues/show_​bug.cgi?id=1654>
>> 3. Queued SVN operations causing hangs (say I revert then switch
>> without waiting for the revert to complete)
>> 4. Tree conflicts that a revert won't fix. Subclipse-invoked cleanups
>> don't help. I have to go to TortoiseSVN to revert.
>> 5. Long delays in the project reflecting the new URL (in Project
>> Explorer) after a switch (actually, that last issue goes as far back as I
>> can remember, though an svn update post-switch seems to refresh it).
>>
>>
>> The first few issues require an Eclipse restart (or often, I have to kill
>> the Eclipse process from Task Manager). I have to restart (or kill) Eclipse
>> several times an hour.
>>
>> Sometimes I'm forced to give up and use TortoiseSVN, but for most things,
>> I prefer Subclipse (when it's working well).
>>
>> Are others having these problems, too? If so, have you, say, downgraded
>> your Subclipse? Have you switched to another Eclipse SVN client?
>>
>> Thanks,
>> Jamie
>>
>>
>>
>
>
> --
> Thanks
>
> Mark Phippard
> http://markphip.blogspot.com/
>
Attachments

« Previous message in topic | 5 of 6 | Next message in topic »

Messages

Show all messages in topic

[Subclipse-users] Latest Subclipse (1.10.13) Unreliable jamiejackson Jamie Jackson 2016-09-08 07:26:01 PDT
     Re: [Subclipse-users] Latest Subclipse (1.10.13) Unreliable markphip Mark Phippard 2016-09-08 07:35:01 PDT
         Re: [Subclipse-users] Latest Subclipse (1.10.13) Unreliable selsemore Stephen Elsemore 2016-09-08 07:39:18 PDT
             Re: [Subclipse-users] Latest Subclipse (1.10.13) Unreliable jamiejackson Jamie Jackson 2016-09-08 10:55:08 PDT
         Re: [Subclipse-users] Latest Subclipse (1.10.13) Unreliable jamiejackson Jamie Jackson 2016-09-08 10:56:00 PDT
             Re: [Subclipse-users] Latest Subclipse (1.10.13) Unreliable markphip Mark Phippard 2016-09-08 11:02:41 PDT
Messages per page: