Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation

subclipse
Discussion topic

Back to topic list

Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation

Author Mark Phippard <markphip at gmail dot com>
Full name Mark Phippard <markphip at gmail dot com>
Date 2007-03-29 08:39:29 PDT
Message On 3/29/07, Jean-Noël Rivasseau <elvanor at gmail dot com> wrote:
>
>
> I am using Eclipse 3.2.2, Subclipse 1.2 under Linux 64 (Gentoo).
>
> Subclipse was working perfectly well until today. For some reason it
> started to have problems, saying:
>
> MESSAGE The SVN synchronization information for 'PPH' has become corrupt
> or does not exist
>
> PPH is the name of my Eclipse project.
>
> I did everything, doing some svn cleanups with the official SVN client,
> closing and reopening the Eclipse project, even reinstalling Subclipse...
> but the problem is still there.
>
> It is bad to the point that everything else in Eclipse does not work, for
> example a right click on an item on the explorer will result in some kind of
> infinite loop, all I can do is kill Eclipse.
>
>
Doing things outside of Eclipse is more likely to create problems than solve
them. Subclipse uses the same code as the command line.

In the messages I notice something about a cache, so where is the cache data
> stored? I should maybe delete that.
>
> If someone can help me, please do by all means - currently my whole
> Eclipse installation is trashed


To delete the cache, close Eclipse. The cache is stored in:

[workspace]/.metadat​a/.plugins/org.eclip​se.core.resources/.p​rojects/PROJECTNAME/​.syncinfo

So you can just find and delete all files named .syncinfo in
[workspace]/.metadat​a/.plugins/org.eclip​se.core.resources/.p​rojects.


--
Thanks

Mark Phippard
http://markphip.blogspot.com/
Attachments

« Previous message in topic | 2 of 12 | Next message in topic »

Messages

Show all messages in topic

Subclipse is trashing my whole Eclipse installation =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> 2007-03-29 08:34:26 PDT
     Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation Mark Phippard <markphip at gmail dot com> Mark Phippard <markphip at gmail dot com> 2007-03-29 08:39:29 PDT
         Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> 2007-03-29 08:54:01 PDT
             Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation Mark Phippard <markphip at gmail dot com> Mark Phippard <markphip at gmail dot com> 2007-03-29 08:57:20 PDT
                 Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> 2007-03-29 09:02:01 PDT
                     Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation Mark Phippard <markphip at gmail dot com> Mark Phippard <markphip at gmail dot com> 2007-03-29 09:06:56 PDT
                         Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> 2007-03-29 09:12:28 PDT
                             Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation Mark Phippard <markphip at gmail dot com> Mark Phippard <markphip at gmail dot com> 2007-03-29 09:15:00 PDT
                                 Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> 2007-03-29 09:17:17 PDT
                                     Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation Mark Phippard <markphip at gmail dot com> Mark Phippard <markphip at gmail dot com> 2007-03-29 09:19:44 PDT
                                         Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> =?UTF-8?Q?Jean-No=C3=ABl_Rivasseau?= <elvanor at gmail dot com> 2007-03-29 09:30:11 PDT
                                             Re: [Subclipse-users] Subclipse is trashing my whole Eclipse installation Miha Vitorovic <mvitorovic at nil dot si> Miha Vitorovic <mvitorovic at nil dot si> 2007-03-29 12:13:10 PDT
Messages per page: