Login | Register
My pages Projects Community openCollabNet

Discussions > users > [Subclipse-users] Having version conflict troubles trying to install 1.4.x after uninstalling 1.6.x

subclipse
Discussion topic

Hide all messages in topic

All messages in topic

RE: [Subclipse-users] Having version conflict troubles trying to install 1.4.x after uninstalling 1.6.x

Author dkarr
Full name David M. Karr
Date 2010-03-08 11:28:37 PST
Message > -----Original Message-----
> From: KARR, DAVID (ATTSI)
> Sent: Monday, March 08, 2010 11:16 AM
> To: users at subclipse dot tigris dot org
> Subject: [Subclipse-users] Having version conflict troubles trying to
> install 1.4.x after uninstalling 1.6.x
>
> Today I'm trying to set up Subclipse in place of Subversive, as I've
> been unable to get help with the problems I'm having with Subversive.
>
> I first installed the 1.6.x version, which was probably a mistake.
> After I installed it and attempted a merge, I got an error that occurs
> when using a > 1.5.x client against a 1.3.x server (yes, that's what
> our
> server version is), which is "Attempt to add tree conflict that
already
> exists". I had gotten this with Subversive, so I'm familiar with it.
> So, I then uninstalled all the Subclipse components and proceeded to
> try
> to install the 1.4.x version, which should resolve this particular
> problem.
>
> After uninstalling 1.6.x and trying to install 1.4.x, the dependency
> check failed with this:

Ah. Never mind. I should have realized the CollabNet merge plugin
would have implicit dependencies that would cause this. After I
uninstalled that, I was able to proceed with the 1.4.x install.

Re: [Subclipse-users] Having version conflict troubles trying to install 1.4.x after uninstalling 1.6.x

Author markphip
Full name Mark Phippard
Date 2010-03-08 11:27:33 PST
Message On Mon, Mar 8, 2010 at 2:15 PM, David M. Karr <dk068x at att dot com> wrote:
> Today I'm trying to set up Subclipse in place of Subversive, as I've
> been unable to get help with the problems I'm having with Subversive.
>
> I first installed the 1.6.x version, which was probably a mistake.
> After I installed it and attempted a merge, I got an error that occurs
> when using a > 1.5.x client against a 1.3.x server (yes, that's what our
> server version is), which is "Attempt to add tree conflict that already
> exists".

I am not aware of that problem being related to a server version, and
even then I thought it was fixed in latest SVN release. Are you on
Windows? If so, nevermind. If you are not, then you might need to
upgrade your SVN libraries to a newer version.

Of course on an older 1.3.x server you cannot use the merge tracking
feature so you would need to always specify the specific revisions to
merge.

>  I had gotten this with Subversive, so I'm familiar with it.
> So, I then uninstalled all the Subclipse components and proceeded to try
> to install the 1.4.x version, which should resolve this particular
> problem.
>
> After uninstalling 1.6.x and trying to install 1.4.x, the dependency
> check failed with this:
>
> ----------------------
> Cannot complete the install because of a conflicting dependency.
>  Software being installed: Subversion Client Adapter - Required 1.5.3
> (org.tigris.subversi​on.clientadapter.fea​ture.feature.group 1.5.3)
>  Software currently installed: CollabNet Merge Client 2.0.1

This is problem here ^^^^

CollabNet Merge Client is included with Subclipse 1.6.x. You will
need to uninstall it, as you did Subclipse. Then you should be able
to install 1.4.x OK.


--
Thanks

Mark Phippard
http://markphip.blogspot.com/

[Subclipse-users] Having version conflict troubles trying to install 1.4.x after uninstalling 1.6.x

Author dkarr
Full name David M. Karr
Date 2010-03-08 11:16:02 PST
Message Today I'm trying to set up Subclipse in place of Subversive, as I've
been unable to get help with the problems I'm having with Subversive.

I first installed the 1.6.x version, which was probably a mistake.
After I installed it and attempted a merge, I got an error that occurs
when using a > 1.5.x client against a 1.3.x server (yes, that's what our
server version is), which is "Attempt to add tree conflict that already
exists". I had gotten this with Subversive, so I'm familiar with it.
So, I then uninstalled all the Subclipse components and proceeded to try
to install the 1.4.x version, which should resolve this particular
problem.

After uninstalling 1.6.x and trying to install 1.4.x, the dependency
check failed with this:

----------------------
Cannot complete the install because of a conflicting dependency.
  Software being installed: Subversion Client Adapter - Required 1.5.3
(org.tigris.subversi​on.clientadapter.fea​ture.feature.group 1.5.3)
  Software currently installed: CollabNet Merge Client 2.0.1
(com.collabnet.subve​rsion.merge.feature.​feature.group 2.0.1)
  Only one of the following can be installed at once:
    Subversion Client Adapter 1.6.8 (org.tigris.subversi​on.clientadapter
1.6.8)
    Subversion Client Adapter 1.5.3 (org.tigris.subversi​on.clientadapter
1.5.3)
  Cannot satisfy dependency:
    From: CollabNet Merge Client 2.0.1
(com.collabnet.subve​rsion.merge.feature.​feature.group 2.0.1)
    To: org.tigris.subversio​n.subclipse.core 1.6.6
  Cannot satisfy dependency:
    From: Subversion Client Adapter - Required 1.5.3
(org.tigris.subversi​on.clientadapter.fea​ture.feature.group 1.5.3)
    To: org.tigris.subversio​n.clientadapter [1.5.3]
  Cannot satisfy dependency:
    From: SVN Team Provider Core 1.6.8
(org.tigris.subversi​on.subclipse.core 1.6.8)
    To: bundle org.tigris.subversio​n.clientadapter [1.6.0,1.7.0)
-------------------

I don't understand how to resolve this. When I go to
"Help"-"About"-"Installation Details", there are no entries beginning
with (or including) "subversion". However, when I go to the "Plug-Ins"
tab, I see "Subversion Client Adapter", version 1.6.8, in the list. So,
it's obviously there, but how do I uninstall it if there's nothing
referencing it in the "Installed Software" tab that I can uninstall?
Messages per page: