Login | Register
My pages Projects Community openCollabNet

Discussions > users > [Subclipse-users] Re: Subversion 1.9 support?

subclipse
Discussion topic

Hide all messages in topic

All messages in topic

RE: Re: [Subclipse-users] Re: Subversion 1.9 support?

Author nethar
Full name Martin Doležal
Date 2015-10-01 01:31:00 PDT
Message Thanks for the update site Mark, it seems to be working fine so far.

Re: [Subclipse-users] Re: Subversion 1.9 support?

Author markphip
Full name Mark Phippard
Date 2015-09-15 13:30:20 PDT
Message I have posted an initial update site that can be used to install SVN 1.9
support. The URL is:

http://subclipse.tig​ris.org/update_1.12.​x

For now, this is the same Subclipse 1.10.x release but with the JavaHL 1.9
plugin. I cannot put them on the same update site and still give people
the option of using SVN 1.8.x so I am going to do it this way for now.
Eventually when and if we add any SVN 1.9-specific features we will change
the Subclipse version to 1.12.x.

The working copies for SVN 1.8 and 1.9 are the same so otherwise there is
no issue in mixing them.

I have been waiting for a few reasons:

SVN 1.9.0 had some bugs reported right away that would have impacted users
so I waited for 1.9.1 to be out. Then some issues also came in for 1.9.1
so I waited some more. I do not think they will be as impactful.

I also mainly work on OS X and Homebrew has not released any 1.9 binaries
yet so I have to stay with 1.8 for main environment.

I did very little testing. This mainly just drops in the new DLL's for
Windows and updates the version checks. JavaHL API should be compatible
and should still work. It seems OK, but we'll see. In the past the main
changes that might be needed would be responding to new notifications.
That will mainly show up in broken console messages if that comes up with
this release.

Mark



On Tue, Sep 15, 2015 at 7:44 AM, Martin Doležal <nethar at seznam dot cz> wrote:

> I can confirm this. Subversion 1.9 does not work with eclipse Luna +
> subclipse 1.10.10. (incompatible javahl library loaded + gnome-keyring
> error). openSUSE 20150909. Any news about future 1.9 support available?
>
> --------------------​--------------------​--------------
>
> http://subclipse.tig​ris.org/ds/viewMessa​ge.do?dsForumId=1047​&dsMessageId=313​7712
>
> To unsubscribe from this discussion, e-mail: [
> users-unsubscribe@su​bclipse.tigris.org].​
>



--
Thanks

Mark Phippard
http://markphip.blogspot.com/
Attachments

RE: [Subclipse-users] Re: Subversion 1.9 support?

Author nethar
Full name Martin Doležal
Date 2015-09-15 04:44:24 PDT
Message I can confirm this. Subversion 1.9 does not work with eclipse Luna + subclipse 1.10.10. (incompatible javahl library loaded + gnome-keyring error). openSUSE 20150909. Any news about future 1.9 support available?

[Subclipse-users] Re: Subversion 1.9 support?

Author Prem Narayan Malav <pnmalav at yahoo dot com>
Full name Prem Narayan Malav <pnmalav at yahoo dot com>
Date 2015-08-16 09:10:10 PDT
Message Mark Phippard <markphip <at> gmail.com> writes:
>
>
> There will not be any issues with a 1.9 server, but we have not started
doing any work on a 1.9 client.  We will, but haven't yet.
> Mark
>
Hi Mark,

After a system upgrade today on Arch linux (x86_64) that came up with
subversion 1.9, eclipse(4.4.2.v20150204-1700) failed to start with
"incompatible javahl library loaded" error and a dialog to disable
gnome-keyring integration. After downgrading subversion to 1.8, eclipse
started normally.
It does seem JavaHL from subversion 1.9 is incompatible with eclipse
subclipse(1.10.9) plugin.

Thanks,
Prem
Messages per page: