Login | Register
My pages Projects Community openCollabNet

Discussions > users > Problems with using create & apply patch

subclipse
Discussion topic

Hide all messages in topic

All messages in topic

Re: [Subclipse-users] Problems with using create & apply patch

Author Mark Phippard <markphip at gmail dot com>
Full name Mark Phippard <markphip at gmail dot com>
Date 2007-07-24 05:51:17 PDT
Message On 7/24/07, Zsolt Koppany <zkoppanylist@int​land.com> wrote:
> I don't know whether this is a subclise issue (I use subclipse-1.2.3 with
> eclipse-3.3) but apply patch shows the modified files correctly and the
> differences seem to be ok but the patch will not be executed, no
> modification will be stored into the working copy.
>
> Subversion merge is unfortunately not an option because the package names
> are already different.
>
> Any ideas?

Apply Patch comes from Eclipse. I know they rewrote it in 3.3. I
have applied several so I know the function does work with Subclipse.
That being said, I have had more problems where it would not apply
parts of the patch than I did with previous versions. In this case,
it creates a file with the .rej extension next to the file it was
patching and this contains the rest of the patch.

--
Thanks

Mark Phippard
http://markphip.blogspot.com/

Problems with using create &amp; apply patch

Author Zsolt Koppany <zkoppanylist at intland dot com>
Full name Zsolt Koppany <zkoppanylist at intland dot com>
Date 2007-07-24 02:18:55 PDT
Message Hi,

I don't know whether this is a subclise issue (I use subclipse-1.2.3 with
eclipse-3.3) but apply patch shows the modified files correctly and the
differences seem to be ok but the patch will not be executed, no
modification will be stored into the working copy.

Subversion merge is unfortunately not an option because the package names
are already different.

Any ideas?

Zsolt
Messages per page: